Malfunzionamento MySQL sul vecchio sito di GIMP Italia

Ciao, segnalo che il vecchio sito (conservato per motivi storici) ha errori nella connessione al DB.

https://gimpitalia.it/migration

https://gimpitalia.it/forum/

1 Like

@Lazza grazie della segnalazione (me ne ero accorto qualche settimana fa e avevo provveduto a sistemare.
@valerio.bozzolan ciao, te ne avevo parlato di recente, evidentemente il riavvio non e’ stato risolutivo.

Qualcun altro ha accesso?
Apriamo un nuovo task su git? =P

1 Like

“Failed to start session: session_start(): Failed to read session data: files (path: /var/lib/php/sessions)”

Grazie Lazza,

Premettendo che questo è un errore di R/W su filesystem e non su database,

Ed è esattamente lo stesso errore che abbiamo avuto la scorsa volta.

Continuiamo la discussione qui:

1 Like

Mmm OK, adesso sul forum si vede qualcosa. Però qui mi dà un errore diverso, sono abbastanza convinto che c’entra qualcosa MySQL.

https://gimpitalia.it/forum/viewforum.php?f=30

Adesso dovrebbe essere sistemato.
Abbiamo poco spazio sulla VM. Dobbiamo migrare o ottimizzare quanto fatto precedentemente.
@Lazza confermi che ci siamo adesso? (ho svecchiato i log di journald)

Il forum funziona, il CMS che gestisce le pagine statiche dà sempre errore:

https://gimpitalia.it/migration

Io lo vedo su, riprovo stasera, magari va ad intermittenza.
Credo, sia rientrato pero’, da dmesg non ho piu’ errori.

A dopo! =D

A me continua a dare errore.

OK grazie ancora Lazza. Oggi ci diamo due calci alla risottata. Probabilmente risolto entro le 17:00. Grazie per la pazienza.

https://risotto.linux.it/2024/04/13/risotterapy-2/

1 Like

@Lazza @oirasor @valerio.bozzolan Grazie mille a tutti per il preziosissimo contributo a non far scomparire il sito storico di Gimp Italia !!!

Fabrizio

@valerio.bozzolan Ma no figurati, grazie a voi… Non c’è fretta. :sweat_smile: Buon risotto!

Pulito gli inode e risolto.
Domanda… la cache di grav / docttine si può ottimizzare in qualche modo?
/var/www/html# bin/grav clean
/var/www/html# bin/grav cache

Clearing cache

Cleared: /var/www/html/cache/twig/*
Cleared: /var/www/html/cache/doctrine/*
Cleared: /var/www/html/cache/compiled/*
Cleared: /var/www/html/images/*
Cleared: /var/www/html/assets/*

Touched: /var/www/html/user/config/system.yaml

After:
Filesystem Inodes IUsed IFree IUse% Mounted on
udev 116K 318 116K 1% /dev
tmpfs 121K 475 121K 1% /run
/dev/vda1 632K 56K 577K 9% /
tmpfs 121K 1 121K 1% /dev/shm
tmpfs 121K 3 121K 1% /run/lock
/dev/vda15 0 0 0 - /boot/efi
tmpfs 25K 11 25K 1% /run/user/1000

Questa volta comunque è risolto davvero =P

1 Like

Vorrei dirti di sì, ma purtroppo temo che l’unica sia mettere un cron che pulisca la cache ogni tot settimane / mesi. :grimacing:

Ok, non conosco Grav/Doctrine, comunque se non troviamo qualcosa di meglio, adotteremo la soluzione a cron, cosi’ non ricapita. inodes #freeAsInFreedom ! xD